511遇见易语言乐玩插件FindColorEx找色扩展

深渊向深渊呼唤

本课视频封装了找色扩展FindColorEx,所谓扩展就是指的能返回所有找到颜色的所有坐标,所以我们要使用数组二次分割来获取颜色的X坐标和Y坐标,才能分别完成鼠标的移动和点击,这个命令不能使用GetX和GetY来获取,具体源码见下面。

乐玩模块源码:

.版本 2
 
.子程序 FindColorEx, 文本型, 公开
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 color, 文本型
.参数 sim, 小数型
.参数 dir
 
返回 (obj.文本方法 (“FindColorEx”, x1, y1, x2, y2, color, sim, dir))

乐玩找色扩展调用源码:

.版本 2
 
.子程序 _按钮7_被单击
.局部变量 str, 文本型
.局部变量 文本, 文本型, , "0"
.局部变量 temp, 文本型, , "0"
.局部变量 x
.局部变量 y
.局部变量 i, 整数型
.局部变量 m
.局部变量 n
 
str = l.FindColorEx (737, 136, 789, 197, “117777-000000|ffeedd-000000”, 1, 2)
文本 = 分割文本 (str, “|”, )
.计次循环首 (取数组成员数 (文本), i)
    temp = 分割文本 (文本 [i], “,”, )
    .判断开始 (temp [1] = “1”)
        x = 到整数 (temp [2])
        y = 到整数 (temp [3])
 
    .判断 (temp [1] = “2”)
        m = 到整数 (temp [2])
        n = 到整数 (temp [3])
    .默认
 
    .判断结束
 
.计次循环尾 ()
 
l.MoveTo (x, y)
l.LeftDoubleClick ()
延时 (1000)
l.MoveTo (m, n)
l.LeftDoubleClick ()

下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

原文:易语言乐玩插件FindColorEx找色扩展

          易语言封装调用乐玩多线程插件模块

您可能感兴趣的文章:


▪ 511遇见易语言多线程大漠多线程-31大漠多线程模板-1子类化

▪ 第12课易语言大漠剑侠情缘多线程木巷菜单功能(完结)

▪ 511遇见易语言多线程大漠多线程-25大漠免注册程序集模块制作方法

▪ 易语言乐玩插件FindPicEx找图扩展找多图

▪ 511遇见易语言多线程大漠多线程-8启动线程传递参数-API自定义数据

▪ 易语言大漠多线程模板-9多线程全部暂停恢复

▪ 第二课易语言大漠剑侠情缘多线程木人巷界面设计

▪ 乐玩插件多线程后台绑定多窗口-方法1

▪ 易语言大漠多线程模板-12游戏实例化

▪ 多线程雷电中控台支持模拟器手游电脑版app应用 

栏目