511遇见易语言乐玩插件字库建立Ocr识别坐标

深渊向深渊呼唤

本课视频录制了字库设置SetDict,字库切换UseDict,Ocr识别,获取窗口标题GetWindowTitle,设置窗口标题,把《剑侠情缘》游戏中的坐标时时显示在游戏窗口标题栏。

乐玩插件字库建立Ocr识别坐标模块源码:

.版本 2

.子程序 SetDict, 整数型, 公开
.参数 index
.参数 file, 文本型
.参数 pwd, 文本型

返回 (obj.数值方法 (“SetDict”, index, file, pwd))

.子程序 UseDict, 整数型, 公开
.参数 index

返回 (obj.数值方法 (“UseDict”, index))

.子程序 Ocr, 文本型, 公开, 返回识别到的字符串
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 color_format, 文本型
.参数 sim, 小数型
.参数 linesign, 文本型
.参数 isbackcolor

返回 (obj.文本方法 (“Ocr”, x1, y1, x2, y2, color_format, sim, linesign, isbackcolor))

.子程序 GetWindowTitle, 文本型, 公开
.参数 hwnd
.参数 flag

返回 (obj.文本方法 (“GetWindowTitle”, hwnd, flag))

.子程序 SetWindowText, 整数型, 公开, 0:失败,1:成功
.参数 hwnd
.参数 title, 文本型

返回 (obj.数值方法 (“SetWindowText”, hwnd, title))

乐玩识字OCR调用源码:

.版本 2
.支持库 spec
.支持库 EThread
 
.子程序 _按钮17_被单击
 
时钟2.时钟周期 = 1000
 
.子程序 识别坐标
.局部变量 ss, 文本型
.局部变量 sss, 文本型
 
ss = l.Ocr (676, 146, 697, 160, “00FF00-000000”, 1, “”, 0)
sss = l.Ocr (702, 145, 720, 161, “00FF00-000000”, 1, “”, 0)
调试输出 (ss)
 
' 标题 = ss + “/” + sss
l.SetWindowText (hwnd, ss + “/” + sss)
 
.子程序 _时钟2_周期事件
 
启动线程 (&识别坐标, , )
 
.子程序 _按钮18_被单击
 
时钟2.时钟周期 = 0
l.SetWindowText (hwnd, game_title)

下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

原文:易语言乐玩插件字库建立Ocr识别坐标

          易语言封装调用乐玩多线程插件模块


您可能感兴趣的文章:


▪ 511遇见易语言多线程大漠多线程-33大漠多线程模板-3UI更新

▪ 511遇见易语言多线程大漠多线程-15Api封装线程挂起恢复销毁

▪ 易语言大漠类单线程加集多线程模块制作及调用实战

▪ 511遇见易语言多线程大漠多线程-22易语言免注册调用大漠插件

▪ 易语言大漠雷电模拟器多开后台绑定-1

▪ 易语言多线程大漠多线程-34大漠多线程模板-4多线程初始化

▪ 乐玩插件多线程模块(索引)--方法3

▪ 易语言大漠单线程多账号循环登陆自动切换任务

▪ 第九课易语言大漠剑侠情缘多线程木人巷对话NPC

▪ 511遇见易语言多线程大漠多线程-2中转子程序传多

栏目