Gradle 6 应用 gradleEnterprise 提示错误

深渊向深渊呼唤

在应用 gradleEnterprise  的时候,提示错误:

> Could not find method gradleEnterprise() for arguments [settings_5wv4b365n0pw4ey5aj1mu1468$_run_closure1@5b527bd] on settings 'covid-19' of type org.gradle.initialization.DefaultSettings.

 


这是因为你可能没有应用插件,你需要在你的 settings.gradle 中添加下面的插件:

plugins {
id "com.gradle.enterprise" version "3.2"
}

配置的内容如下:

plugins {
    id "com.gradle.enterprise" version "3.2"
}

gradleEnterprise {
    buildScan {
        termsOfServiceUrl = 'https://gradle.com/terms-of-service'
        termsOfServiceAgree = 'yes'
    }
}

需要先应用 com.gradle.enterprise 插件

https://www.cwiki.us/display/GradleZH/questions/57938718

栏目